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Microsoft Excel 2 

 Intermediate-Level Features of Excel 2013 

 

 

Review: Formulas 

A formula is mathematical statement written by the user to be calculated. Formulas can be as simple 

or as complex as the user wants.  

NOTE: In Excel, the syntax for ALL functions and formulas begins with an equals sign (=) 

This informs Excel that what you type is a formula and not simply another word or number.  

1. Click the cell where you want the formula result to appear (for example, C1). 

2. All functions must start with the equal sign. Type the equal sign (=) into the formula bar. 

3. Click or type the cell that contains the first value you want in the formula (for example, A1). 

4. Type a mathematical operator  

a. All functions use the following 

mathematical operators: 

i. Addition (+) 

ii. Subtraction (-) 

iii. Multiplication (*) 

iv. Division (/) 

5. Click on or type the cell that contains the 

second value you want in the formula (for 

example, B1) 

6. Click Enter to calculate your formula 

(=A1+B1).  

7. Review: Auto Fill 

The Auto Fill feature inputs information without retyping it in each box. You can type “January” and 

Auto Fill can fill in the rest of the months. The same works for numbers, days of the week and other 

text data series.  Auto Fill can also repeat a formula across many rows or columns. 

To use Auto Fill, simply select a cell containing a data series then left-click and drag on the fill handle 

 (small, black square in lower-right corner) to select the cells you wish to Auto Fill. After you 
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release the mouse button, an Auto Fill Options button is displayed just below and to the right of the 

last cell you just Auto Filled. Click on this button to choose alternative options of how to fill the cells. 

 

 Review: AutoSum 

AutoSum will do math on all the numbers in a column or row very quickly and easily. In the Excel 1 

class, we used AutoSum only to add all the numbers together. AutoSum can also do other functions, 

such as finding the average of a row or column, or finding the 

highest or lowest number (max and min).  

To use AutoSum: 

1. Click in the cell you want your answer to appear in 

2. Click the Down Arrow of the AutoSum button on the Formula 

tab  

3. Choose which type of math you want to do 

4. Highlight the numbers you want to use AutoSum on. A dotted 

box should show up around them. You can also manually 

change the cells in the cells in the formula bar. **NOTE: if you 

already have totals in your column or row make sure that they are NOT 

selected 

5. Press Enter 

 

Practice using AutoSum to calculate the total Profit (SUM) , average Profit 

(AVG), maximum Profit (MAX), and minimum Profit (MIN).  

Make sure that when you select the cells to do your AutoSum to that you 

don’t include the cells for the other AutoSum totals, only the data! 

 

 

2 1 
1 

 

Fill handle (drag it) 

2 

 

Auto Fill Options button (click on it) 

Auto Fill also works for AutoSum! Just use 

the same method you used for formulas. 

SUM 

AVE 

MAX 

MIN 
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Formatting Cells 

When you enter data into a cell in Excel, it is handled differently depending on what type of formatting 

you have assigned. For example, if you choose Currency formatting, Excel will automatically convert 3 

into $3.00; if you choose Date formatting, Excel would convert “3/1” to “March 1, 2013”; and if you 

choose Percent formatting, Excel would change “0.3” to “30%”.  

1. Select the specific cell, row, or column you want to format. 

2. Find the Number section in the Home tab 

3. Click the down arrow to choose the category you want for your data and then  pick  

a specific type (how you want  

it to appear). There are also buttons for Currency, 

Percentage, and Decimal Point to make those faster. 

 

  
        Money Percent  Decimal 

Sorting Data in Lists 

Sorting is a common task that allows you to change or customize the order of your spreadsheet data to 

better organize your information. Data can be sorted by text (in ascending A to Z, or descending Z to A 

order), numbers (smallest to largest or largest to smallest), or by dates (newest first or oldest first). 

Using the custom sort dialog, you can also sort by many other criteria: formats, colors, fonts, etc.  

Type in the table below: 

Note: Type in Volunteers at PPL in Cell A1, and 

then merge and center by highlighting from cell 

A1 to D1 and clicking on .  This button is 

located on the home tab in the alignment 

group. 
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Perform a simple sort: 

1. Select the column or row you want to sort. You may need to 

highlight with the mouse as to not select Totals. 

2. The Sort & Filter button is located on the home tab in the 

editing group.  This area allows you to make complicated and 

custom sorts, but for most purposes, people can just use the 

Sort A to Z or the Sort Z to A menu items to quickly sort: 

 Alphabetically 

 Number Order 

 Date and Time  

 

 

Always expand the selection so that your data 

stays together across all the different 

categories! 

 

Perform a custom sort: 

A custom sort may be necessary to do sorts that don’t fit in to the alphabetical or numerical sort, such 

as days of the week. 

1. Select the entire table including the headers. 

2. On the ribbon click on Sort & Filter and then click on Custom Sort… 

3. In the following Sort box that appears, change the field in Sort by to Day Free. 

4. In the Order field, select Custom List… 

5. In the Custom List box that appears, Select the custom list that says: Sun, Mon, Tue, Wed, Thu.. 

6. Click OK, and then ok once more in the Sort box.  Your table should be sorted by the days of the 

week! 
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Filtering Data 

Filtering allows you to show only cells that have certain information in them. Once enabled, you can 

quickly filter your data based on criteria you specify. Excel will only display the rows meeting the 

criteria, hiding the other rows.  

To Filter: 
1. Make the data type is the same within the column (i.e. all text, all 

numbers, all dates, etc.) and the column has a column heading 
2. Click inside any data cell that is among the ones to be filtered 
3. On the ribbon, click on the Data tab  
4. In  Sort & Filter area, click Filter 
5. Notice that a small down arrow appears on your column heading.  

**Note: Filtering DOES NOT work without a column 
heading 

6. Click on the arrow by the heading to display the filter data 
options. Check the categories you want to appear, and uncheck 
the categories you do not want to appear. 

7. To deactivate the filter, just click on (Select All). To make the 
arrow go away, click on the Filter button in the Sort & Filter area 
on the ribbon.  

 

 

 

 

 

 

 

 

 

 



 

 

This work was created by PPL.  

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 License. You are free to copy, distribute, transmit, and adapt 

this work provided that this use is of a non-commercial nature, that any subsequent adaptations of the work are placed under a similar license, and that 

appropriate attribution is provided where possible. 

Page 6 of 10 

Subtotals  

Subtotals are another built-in tool that can be quickly applied to subtotal data in a sorted list. When 

used, the Subtotal tool will insert a blank row at each change of data and add a summary function 

(such as SUM, AVERAGE, COUNT, MINIMUM or MAXIMUM), as well as a Grand Total calculation at the 

bottom of the data set. 

**Before enabling subtotals, your data must be sorted by the field you wish to subtotal **  

Type in the Following Example: 
 
 
 
 
 
 
To Add Subtotals  

1. Sort your data 

2. Highlight your data including the column headings 

3. On the Data tab click the Subtotal button in the 

Outline area 

4. In the “At each change in:” drop-down list, choose 

the sorted column that triggers a subtotal calculation 

when the data changes value (person, day, product, 

etc.) 

5. In the “Add subtotal to:” drop-down list, choose the 

column whose data will be used in the subtotal 

calculation (usually money) 

6. In the “Use function:” drop-down list, choose what 

math function you want to use on the subtotaled 

column    

To Remove Subtotals  
1. Select a cell in the Database  
2. On the Data tab click the Subtotals button  
3. Click the Remove All button 

 

Salesperson Units Sold Day 

Jim 5 Mon 

Mary 13 Mon 

Jim 7 Tue 

Mary 6 Tue 

Jim 9 Wed 

Mary 8 Wed 
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What it should look like after subtotals are added: 

 

 

 

 

 

Conditional Formatting:  Allows you to create rules for when and how cells are formatted based 

on the contents of the cell. For example, you can set conditional formatting so that a cell turns blue or 

green, based on its value. 

To turn on: 

1. Select all of your data 

2. Click the Conditional Formatting button on the Home Tab 

3. Click Highlight Cells Rules 

4. Choose a rule and formatting option to make those cells stand out. Example:  For data values 

greater than 12, use light red fill with dark red text. 

Under conditional formatting, you can also add icon sets and/or color scales to show patterns in your 

data 

To turn off: 

1. Click the Conditional Formatting button on the Home Tab 

2. Select Clear Rules 

3. Choose Clear Rules from Entire Sheet 

 

  

Salesperson Units Sold Day 

Jim 5 Mon 

Mary 13 Mon 

 18 Mon Total 

Jim 7 Tue 

Mary 6 Tue 

 13 Tue Total 

Jim 9 Wed 

Mary 8 Wed 

 17 Wed Total 

 48 Grand Total 
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Format as a table: Formatting your spreadsheet as a table can make it look better and in some 

cases can also make it easier to manage. 

1. Highlight all of the data cells and column headers you want to include in your table 

2. Under the Home tab, click on Format as Table 

3. Choose a table that looks nice. 

4. Click “OK” to choose the data for your table when the box pops up 

When you highlight a table, a new Design tab appears in the ribbon where you can change the look of 

your table. 
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LET’S PRACTICE WHAT WE LEARNED 

1. Type the following unsorted data into a spreadsheet: 

 

Salesman Units Sold Day

Jim 5 Mon

Jim 7 Tue

Jim 9 Wed

Mary 13 Mon

Mary 6 Tue

Mary 8 Wed  

2. Select ALL of the data in these cells, including the column headers (titles) 

3. On the ribbon click on the Data tab 

4. Click on the Sort button to pop up the Sort Dialog Box (see image below) 

5. Make these selections in the Sort Dialog Box: 

 Sort by: Day 

 Sort on: Values 

 Order: Custom List… then Sun, Mon, Tue, Wed, Thu, Fri, Sat (this orders data by the day 

of the week) 
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The sorted data should look like this where the Mondays are grouped together, etc.: 

 

Salesman Units Sold Day

Jim 5 Mon

Mary 13 Mon

Jim 7 Tue

Mary 6 Tue

Jim 9 Wed

Mary 8 Wed  
 

6. Now temporarily filter out (hide) the data entries for Tue. 

7. Click inside any data cell in the above data group 
8. On the ribbon, click on the Data tab  
9. In  Sort & Filter area, click Filter 
10. Click on the Down Arrow next to the Day column heading, uncheck the box for Tue then click 

on the OK button 

11. Notice that the two rows containing Tue are now hidden. Press Ctrl-Z to undo the filtering and 

display the Tue entries  

12. Subtotal the Units Sold by day (Mon, Tue, Wed)  

13. Now change the Units Sold subtotal to an average instead of a sum for each day 

14. Turn off subtotals (Hint: Click on a data cell -> click on Subtotal -> Remove All) 

15. Highlight the data under the Units Sold column and click on Conditional Formatting ->  

Select Highlight Cells Rules -> Greater Than… -> 7 -> with Light Red Fill with Dark Red Text 

Select Highlight Cells Rules -> Less Than… -> 7 -> with Light Green Fill with Dark Green Text 

Select Highlight Cells Rules -> Equal To… -> 7 -> with Light Yellow Fill with Dark Yellow Text 

16. Turn off Conditional Formatting (Hint: Select only the data cells -> Conditional Formatting -> 

Clear Rules -> Clear Rules from Selected Cells) 

17. Format your data cells and header columns as a light orange table. (Hint: Select the cells ->  

Format as Table -> Table Style Light 14) 


